const regex = /.*?\s*\|\s*(.*?)\s*\|.*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*?\\s*\\|\\s*(.*?)\\s*\\|.*', 'g')
const str = `Live => [US] United States | example1@yahoo.com | Checked on 5:59 pm - May 17, 2015
Live => [US] United States | example2@yahoo.com | Checked on 5:59 pm - May 17, 2015
Live => [US] United States | example3@yahoo.com | Checked on 5:59 pm - May 17, 2015
Live => [US] United States | example4@yahoo.com | Checked on 5:59 pm - May 17, 2015
Live => [US] United States | example5@yahoo.com | Checked on 5:59 pm - May 17, 2015 `;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);