# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r".*?\s*\|\s*(.*?)\s*\|.*"
test_str = ("Live => [US] United States | example1@yahoo.com | Checked on 5:59 pm - May 17, 2015 \n"
"Live => [US] United States | example2@yahoo.com | Checked on 5:59 pm - May 17, 2015 \n"
"Live => [US] United States | example3@yahoo.com | Checked on 5:59 pm - May 17, 2015 \n"
"Live => [US] United States | example4@yahoo.com | Checked on 5:59 pm - May 17, 2015 \n"
"Live => [US] United States | example5@yahoo.com | Checked on 5:59 pm - May 17, 2015 ")
subst = "$1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.