// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r".*?\s*\|\s*(.*?)\s*\|.*").unwrap();
let string = "Live => [US] United States | example1@yahoo.com | Checked on 5:59 pm - May 17, 2015
Live => [US] United States | example2@yahoo.com | Checked on 5:59 pm - May 17, 2015
Live => [US] United States | example3@yahoo.com | Checked on 5:59 pm - May 17, 2015
Live => [US] United States | example4@yahoo.com | Checked on 5:59 pm - May 17, 2015
Live => [US] United States | example5@yahoo.com | Checked on 5:59 pm - May 17, 2015 ";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}