#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^-?(?!.*0$)(?!0\d)\d+(?:[,.]\d+)?$"
Local $sString = "23,560" & @CRLF & _
"1289,4" & @CRLF & _
"1,9" & @CRLF & _
"63478,1252" & @CRLF & _
"0,3265" & @CRLF & _
"086,344" & @CRLF & _
"34,7000" & @CRLF & _
"-0,2" & @CRLF & _
"-333,44" & @CRLF & _
"-33,550" & @CRLF & _
"-44.66" & @CRLF & _
"-0.005" & @CRLF & _
"0,66" & @CRLF & _
"-0" & @CRLF & _
"0" & @CRLF & _
"55"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")