$re = '/^-?(?!.*0$)(?!0\d)\d+(?:[,.]\d+)?$/m';
$str = '23,560
1289,4
1,9
63478,1252
0,3265
086,344
34,7000
-0,2
-333,44
-33,550
-44.66
-0.005
0,66
-0
0
55';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);