import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^-?(?!.*0$)(?!0\\d)\\d+(?:[,.]\\d+)?$";
final String string = "23,560\n"
+ "1289,4\n"
+ "1,9\n"
+ "63478,1252\n"
+ "0,3265\n"
+ "086,344\n"
+ "34,7000\n"
+ "-0,2\n"
+ "-333,44\n"
+ "-33,550\n"
+ "-44.66\n"
+ "-0.005\n"
+ "0,66\n"
+ "-0\n"
+ "0\n"
+ "55";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}