const regex = /^-?(?!.*0$)(?!0\d)\d+(?:[,.]\d+)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^-?(?!.*0$)(?!0\\d)\\d+(?:[,.]\\d+)?$', 'gm')
const str = `23,560
1289,4
1,9
63478,1252
0,3265
086,344
34,7000
-0,2
-333,44
-33,550
-44.66
-0.005
0,66
-0
0
55`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}