using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^-?(?!.*0$)(?!0\d)\d+(?:[,.]\d+)?$";
string input = @"23,560
1289,4
1,9
63478,1252
0,3265
086,344
34,7000
-0,2
-333,44
-33,550
-44.66
-0.005
0,66
-0
0
55";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}