# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^-?(?!.*0$)(?!0\d)\d+(?:[,.]\d+)?$"
test_str = ("23,560\n"
"1289,4\n"
"1,9\n"
"63478,1252\n"
"0,3265\n"
"086,344\n"
"34,7000\n"
"-0,2\n"
"-333,44\n"
"-33,550\n"
"-44.66\n"
"-0.005\n"
"0,66\n"
"-0\n"
"0\n"
"55")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.