#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:(?P<Port>\w+(?:(?:[\/]\d)?)+(?:(?:[.]\d)?)+)\s+(?P<Name>[\w_\/]+)?\s+(?P<Status>\w+)\s+(?P<Vlan>\w+)\s+(?P<Duplex>\w+)\s+(?P<Speed>\w+)\s+(?P<Type>[\w\-]+)(?:\s+)?)"
Local $sString = "Port Name Status Vlan Duplex Speed Type" & @CRLF & _
"Te1/1.5 disabled 1 full 10G 10Gbase-LX4" & @CRLF & _
"Te1/2 disabled 1 full 10G 10Gbase-LX4" & @CRLF & _
"Te1/3 disabled 1 full 10G 10Gbase-LR" & @CRLF & _
"Te1/4 disabled 1 full 10G 10Gbase-LX4" & @CRLF & _
"Gi2/1 ES1SW70AUN2_1/2/12 connected trunk full 1000 1000BaseSX" & @CRLF & _
"Gi2/2 ES1SW70AUN2_2/2/12 connected trunk full 1000 1000BaseSX" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")