use strict;
my $str = 'Port Name Status Vlan Duplex Speed Type
Te1/1.5 disabled 1 full 10G 10Gbase-LX4
Te1/2 disabled 1 full 10G 10Gbase-LX4
Te1/3 disabled 1 full 10G 10Gbase-LR
Te1/4 disabled 1 full 10G 10Gbase-LX4
Gi2/1 ES1SW70AUN2_1/2/12 connected trunk full 1000 1000BaseSX
Gi2/2 ES1SW70AUN2_2/2/12 connected trunk full 1000 1000BaseSX
';
my $regex = qr/(?:(?P<Port>\w+(?:(?:[\/]\d)?)+(?:(?:[.]\d)?)+)\s+(?P<Name>[\w_\/]+)?\s+(?P<Status>\w+)\s+(?P<Vlan>\w+)\s+(?P<Duplex>\w+)\s+(?P<Speed>\w+)\s+(?P<Type>[\w\-]+)(?:\s+)?)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}