package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:(?P<Port>\w+(?:(?:[\/]\d)?)+(?:(?:[.]\d)?)+)\s+(?P<Name>[\w_\/]+)?\s+(?P<Status>\w+)\s+(?P<Vlan>\w+)\s+(?P<Duplex>\w+)\s+(?P<Speed>\w+)\s+(?P<Type>[\w\-]+)(?:\s+)?)`)
var str = `Port Name Status Vlan Duplex Speed Type
Te1/1.5 disabled 1 full 10G 10Gbase-LX4
Te1/2 disabled 1 full 10G 10Gbase-LX4
Te1/3 disabled 1 full 10G 10Gbase-LR
Te1/4 disabled 1 full 10G 10Gbase-LX4
Gi2/1 ES1SW70AUN2_1/2/12 connected trunk full 1000 1000BaseSX
Gi2/2 ES1SW70AUN2_2/2/12 connected trunk full 1000 1000BaseSX
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}