import Foundation
let pattern = #"(?:(?P<Port>\w+(?:(?:[\/]\d)?)+(?:(?:[.]\d)?)+)\s+(?P<Name>[\w_\/]+)?\s+(?P<Status>\w+)\s+(?P<Vlan>\w+)\s+(?P<Duplex>\w+)\s+(?P<Speed>\w+)\s+(?P<Type>[\w\-]+)(?:\s+)?)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Port Name Status Vlan Duplex Speed Type
Te1/1.5 disabled 1 full 10G 10Gbase-LX4
Te1/2 disabled 1 full 10G 10Gbase-LX4
Te1/3 disabled 1 full 10G 10Gbase-LR
Te1/4 disabled 1 full 10G 10Gbase-LX4
Gi2/1 ES1SW70AUN2_1/2/12 connected trunk full 1000 1000BaseSX
Gi2/2 ES1SW70AUN2_2/2/12 connected trunk full 1000 1000BaseSX
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)