const regex = new RegExp('(?:(?P<Port>\\w+(?:(?:[\\/]\\d)?)+(?:(?:[.]\\d)?)+)\\s+(?P<Name>[\\w_\\/]+)?\\s+(?P<Status>\\w+)\\s+(?P<Vlan>\\w+)\\s+(?P<Duplex>\\w+)\\s+(?P<Speed>\\w+)\\s+(?P<Type>[\\w\\-]+)(?:\\s+)?)', 'gm')
const str = `Port Name Status Vlan Duplex Speed Type
Te1/1.5 disabled 1 full 10G 10Gbase-LX4
Te1/2 disabled 1 full 10G 10Gbase-LX4
Te1/3 disabled 1 full 10G 10Gbase-LR
Te1/4 disabled 1 full 10G 10Gbase-LX4
Gi2/1 ES1SW70AUN2_1/2/12 connected trunk full 1000 1000BaseSX
Gi2/2 ES1SW70AUN2_2/2/12 connected trunk full 1000 1000BaseSX
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}