import re
regex = re.compile(r"(?:(?P<Port>\w+(?:(?:[\/]\d)?)+(?:(?:[.]\d)?)+)\s+(?P<Name>[\w_\/]+)?\s+(?P<Status>\w+)\s+(?P<Vlan>\w+)\s+(?P<Duplex>\w+)\s+(?P<Speed>\w+)\s+(?P<Type>[\w\-]+)(?:\s+)?)", flags=re.MULTILINE)
test_str = ("Port Name Status Vlan Duplex Speed Type\n"
"Te1/1.5 disabled 1 full 10G 10Gbase-LX4\n"
"Te1/2 disabled 1 full 10G 10Gbase-LX4\n"
"Te1/3 disabled 1 full 10G 10Gbase-LR\n"
"Te1/4 disabled 1 full 10G 10Gbase-LX4\n"
"Gi2/1 ES1SW70AUN2_1/2/12 connected trunk full 1000 1000BaseSX\n"
"Gi2/2 ES1SW70AUN2_2/2/12 connected trunk full 1000 1000BaseSX\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")