using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"f=<([\w\-.]+@[\w\-.]+)> t=<([\w\-.]+@[\w\-.]+)>";
string input = @"f=<remolabarca0@abcde.com> t=<remo_labarca1@hotmail.virgilio.com> t=<vacca.carlo@live.org>";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}