re = /f=<([\w\-.]+@[\w\-.]+)> t=<([\w\-.]+@[\w\-.]+)>/
str = 'f=<remolabarca0@abcde.com> t=<remo_labarca1@hotmail.virgilio.com> t=<vacca.carlo@live.org>'
# Print the match result
str.match(re) do |match|
puts match.to_s
end