// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"f=<([\w\-.]+@[\w\-.]+)> t=<([\w\-.]+@[\w\-.]+)>").unwrap();
let string = "f=<remolabarca0@abcde.com> t=<remo_labarca1@hotmail.virgilio.com> t=<vacca.carlo@live.org>";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}