$re = '/f=<([\w\-.]+@[\w\-.]+)> t=<([\w\-.]+@[\w\-.]+)>/';
$str = 'f=<remolabarca0@abcde.com> t=<remo_labarca1@hotmail.virgilio.com> t=<vacca.carlo@live.org>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);