package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`f=<([\w\-.]+@[\w\-.]+)> t=<([\w\-.]+@[\w\-.]+)>`)
var str = `f=<remolabarca0@abcde.com> t=<remo_labarca1@hotmail.virgilio.com> t=<vacca.carlo@live.org>`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}