using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([^\s\{]+?(?=:))(:\s)([^;]*);";
string substitution = @":$1 ""$3""";
string input = @" width: 220px;
height: 50px;
border-radius: 2px;
background-color: #269ce2;
box-shadow: 0 1px 2px 0 rgba(0, 0, 0, 0.12);
border: solid 1px #228cc9;
font-family: AvenirNext-Medium;
font-size: 16px;
text-align: center;
color: #ffffff;";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}