import re
regex = re.compile(r"([^\s\{]+?(?=:))(:\s)([^;]*);")
test_str = (" width: 220px;\n"
" height: 50px;\n"
" border-radius: 2px;\n"
" background-color: #269ce2;\n"
" box-shadow: 0 1px 2px 0 rgba(0, 0, 0, 0.12);\n"
" border: solid 1px #228cc9;\n"
" font-family: AvenirNext-Medium;\n"
" font-size: 16px;\n"
" text-align: center;\n"
" color: #ffffff;")
subst = ":$1 \"$3\""
result = regex.sub(subst, test_str)
if result:
print(result)