use strict;
my $str = ' width: 220px;
height: 50px;
border-radius: 2px;
background-color: #269ce2;
box-shadow: 0 1px 2px 0 rgba(0, 0, 0, 0.12);
border: solid 1px #228cc9;
font-family: AvenirNext-Medium;
font-size: 16px;
text-align: center;
color: #ffffff;';
my $regex = qr/([^\s\{]+?(?=:))(:\s)([^;]*);/p;
my $subst = ':$1 "$3"';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";