const regex = /([^\s\{]+?(?=:))(:\s)([^;]*);/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([^\\s\\{]+?(?=:))(:\\s)([^;]*);', 'g')
const str = ` width: 220px;
height: 50px;
border-radius: 2px;
background-color: #269ce2;
box-shadow: 0 1px 2px 0 rgba(0, 0, 0, 0.12);
border: solid 1px #228cc9;
font-family: AvenirNext-Medium;
font-size: 16px;
text-align: center;
color: #ffffff;`;
const subst = `:$1 "$3"`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);