import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([^\\s\\{]+?(?=:))(:\\s)([^;]*);";
final String string = " width: 220px;\n"
+ " height: 50px;\n"
+ " border-radius: 2px;\n"
+ " background-color: #269ce2;\n"
+ " box-shadow: 0 1px 2px 0 rgba(0, 0, 0, 0.12);\n"
+ " border: solid 1px #228cc9;\n"
+ " font-family: AvenirNext-Medium;\n"
+ " font-size: 16px;\n"
+ " text-align: center;\n"
+ " color: #ffffff;";
final String subst = ":$1 \"$3\"";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}