# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?!^)\b(\w)\w+/$1./gm;t' <<< "John Smith
Kim Jong Un
David X. Cohen
Bob"