$re = '/(?!^)\b(\w)\w+/m';
$str = 'John Smith
Kim Jong Un
David X. Cohen
Bob';
$subst = "$1.";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;