use strict;
my $str = 'John Smith
Kim Jong Un
David X. Cohen
Bob';
my $regex = qr/(?!^)\b(\w)\w+/mp;
my $subst = '$1.';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";