using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?!^)\b(\w)\w+";
string substitution = @"$1.";
string input = @"John Smith
Kim Jong Un
David X. Cohen
Bob";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}