#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?!^)\b(\w)\w+"
Local $sString = "John Smith" & @CRLF & _
"Kim Jong Un" & @CRLF & _
"David X. Cohen" & @CRLF & _
"Bob"
Local $sSubst = "$1."
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)