re = /(?!^)\b(\w)\w+/m
str = 'John Smith
Kim Jong Un
David X. Cohen
Bob'
subst = '$1.'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result