# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\s*(?:(.*)\s+\{\{while\s+(.*)\}\}.*\r?\n\s*(.*)\r?\n\s*(.*)\r?\n\s*(.*)\r?\n.*)/'$1', [$2], $3, $4 and $5/;t' <<< "<html lang=\"{{var doc-lang}}\">
<head>
<title>{{var doc-title}}</div>
</head>
<body>
<div class=\"container\">
<div class=\"row\" {{while products}}>
{{var name}}
{{var sku}}
{{var barcode}}
</div {{while end}}>
</div>
</body>
</html>"