#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\s*(?:(.*)\s+\{\{while\s+(.*)\}\}.*\r?\n\s*(.*)\r?\n\s*(.*)\r?\n\s*(.*)\r?\n.*)"
Local $sString = "<html lang="{{var doc-lang}}">" & @CRLF & _
"<head>" & @CRLF & _
"<title>{{var doc-title}}</div>" & @CRLF & _
"</head>" & @CRLF & _
"<body>" & @CRLF & _
"<div class="container">" & @CRLF & _
" <div class="row" {{while products}}>" & @CRLF & _
" {{var name}}" & @CRLF & _
" {{var sku}}" & @CRLF & _
" {{var barcode}}" & @CRLF & _
" </div {{while end}}>" & @CRLF & _
"</div>" & @CRLF & _
"</body>" & @CRLF & _
"</html>"
Local $sSubst = "'$1', [$2], $3, $4 and $5"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)