using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s*(?:(.*)\s+\{\{while\s+(.*)\}\}.*\r?\n\s*(.*)\r?\n\s*(.*)\r?\n\s*(.*)\r?\n.*)";
string substitution = @"'$1', [$2], $3, $4 and $5";
string input = @"<html lang=""{{var doc-lang}}"">
<head>
<title>{{var doc-title}}</div>
</head>
<body>
<div class=""container"">
<div class=""row"" {{while products}}>
{{var name}}
{{var sku}}
{{var barcode}}
</div {{while end}}>
</div>
</body>
</html>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}