import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\s*(?:(.*)\\s+\\{\\{while\\s+(.*)\\}\\}.*\\r?\\n\\s*(.*)\\r?\\n\\s*(.*)\\r?\\n\\s*(.*)\\r?\\n.*)";
final String string = "<html lang=\"{{var doc-lang}}\">\n"
+ "<head>\n"
+ "<title>{{var doc-title}}</div>\n"
+ "</head>\n"
+ "<body>\n"
+ "<div class=\"container\">\n"
+ " <div class=\"row\" {{while products}}>\n"
+ " {{var name}}\n"
+ " {{var sku}}\n"
+ " {{var barcode}}\n"
+ " </div {{while end}}>\n"
+ "</div>\n"
+ "</body>\n"
+ "</html>";
final String subst = "'$1', [$2], $3, $4 and $5";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}