# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\s*(?:(.*)\s+\{\{while\s+(.*)\}\}.*\r?\n\s*(.*)\r?\n\s*(.*)\r?\n\s*(.*)\r?\n.*)"
test_str = ("<html lang=\"{{var doc-lang}}\">\n"
"<head>\n"
"<title>{{var doc-title}}</div>\n"
"</head>\n"
"<body>\n"
"<div class=\"container\">\n"
" <div class=\"row\" {{while products}}>\n"
" {{var name}}\n"
" {{var sku}}\n"
" {{var barcode}}\n"
" </div {{while end}}>\n"
"</div>\n"
"</body>\n"
"</html>")
subst = "'$1', [$2], $3, $4 and $5"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 1)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.