// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\s*(?:(.*)\s+\{\{while\s+(.*)\}\}.*\r?\n\s*(.*)\r?\n\s*(.*)\r?\n\s*(.*)\r?\n.*)").unwrap();
let string = "<html lang=\"{{var doc-lang}}\">
<head>
<title>{{var doc-title}}</div>
</head>
<body>
<div class=\"container\">
<div class=\"row\" {{while products}}>
{{var name}}
{{var sku}}
{{var barcode}}
</div {{while end}}>
</div>
</body>
</html>";
let substitution = "'$1', [$2], $3, $4 and $5";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}