#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "function\s([a-zA-Z]*)\((.*)\)\{"
Local $sString = "function test(a,b,c){"
Local $sSubst = "function $1 ($2) {"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)