const regex = /function\s([a-zA-Z]*)\((.*)\)\{/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('function\\s([a-zA-Z]*)\\((.*)\\)\\{', '')
const str = `function test(a,b,c){`;
const subst = `function $1 ($2) {`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);