import re
regex = re.compile(r"function\s([a-zA-Z]*)\((.*)\)\{")
test_str = "function test(a,b,c){"
subst = "function $1 ($2) {"
result = regex.sub(subst, test_str, count=1)
if result:
print(result)