using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"function\s([a-zA-Z]*)\((.*)\)\{";
string substitution = @"function $1 ($2) {";
string input = @"function test(a,b,c){";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}