import Foundation
let pattern = #"function\s([a-zA-Z]*)\((.*)\)\{"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"function test(a,b,c){"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"function $1 ($2) {"#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}