re = /function\s([a-zA-Z]*)\((.*)\)\{/
str = 'function test(a,b,c){'
subst = 'function $1 ($2) {'
result = str.sub(re, subst)
# Print the result of the substitution
puts result