// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"function\s([a-zA-Z]*)\((.*)\)\{").unwrap();
let string = "function test(a,b,c){";
let substitution = "function $1 ($2) {";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}