#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "/test1/test2/(?!new\.jpg).*"
Local $sString = "/test1/test2/a.png" & @CRLF & _
"/test1/test2/b.png" & @CRLF & _
"/test1/test2/new.jpg" & @CRLF & _
"/test1/test2/c.png"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")