import re
regex = re.compile(r"/test1/test2/(?!new\.jpg).*")
test_str = ("/test1/test2/a.png\n"
"/test1/test2/b.png\n"
"/test1/test2/new.jpg\n"
"/test1/test2/c.png")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")