const regex = new RegExp('/test1/test2/(?!new\\.jpg).*', 'g')
const str = `/test1/test2/a.png
/test1/test2/b.png
/test1/test2/new.jpg
/test1/test2/c.png`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}