re = /\/test1\/test2\/(?!new\.jpg).*/
str = '/test1/test2/a.png
/test1/test2/b.png
/test1/test2/new.jpg
/test1/test2/c.png'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end