using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"/test1/test2/(?!new\.jpg).*";
string input = @"/test1/test2/a.png
/test1/test2/b.png
/test1/test2/new.jpg
/test1/test2/c.png";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}