$re = '//test1/test2/(?!new\.jpg).*/';
$str = '/test1/test2/a.png
/test1/test2/b.png
/test1/test2/new.jpg
/test1/test2/c.png';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);